Think you have a false positive on this rule?

Sid 1-21154

Message

BROWSER-FIREFOX Mozilla products floating point buffer overflow attempt

Summary

Array index error in the (1) dtoa implementation in dtoa.c (aka pdtoa.c) and the (2) gdtoa (aka new dtoa) implementation in gdtoa/misc.c in libc, as used in multiple operating systems and products including in FreeBSD 6.4 and 7.2, NetBSD 5.0, OpenBSD 4.5, Mozilla Firefox 3.0.x before 3.0.15 and 3.5.x before 3.5.4, K-Meleon 1.5.3, SeaMonkey 1.1.8, and other products, allows context-dependent attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a large precision value in the format argument to a printf function, which triggers incorrect memory allocation and a heap-based buffer overflow during conversion to a floating-point number.

Impact

CVSS base score 6.8 CVSS impact score 6.4 CVSS exploitability score 8.6 confidentialityImpact PARTIAL integrityImpact PARTIAL availabilityImpact PARTIAL

CVE-2009-0689:

CVSS base score 6.8

CVSS impact score 6.4

CVSS exploitability score 8.6

Confidentiality Impact PARTIAL

Integrity Impact PARTIAL

Availability Impact PARTIAL

Detailed information

CVE-2009-0689: Array index error in the (1) dtoa implementation in dtoa.c (aka pdtoa.c) and the (2) gdtoa (aka new dtoa) implementation in gdtoa/misc.c in libc, as used in multiple operating systems and products including in FreeBSD 6.4 and 7.2, NetBSD 5.0, OpenBSD 4.5, Mozilla Firefox 3.0.x before 3.0.15 and 3.5.x before 3.5.4, K-Meleon 1.5.3, SeaMonkey 1.1.8, and other products, allows context-dependent attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a large precision value in the format argument to a printf function, which triggers incorrect memory allocation and a heap-based buffer overflow during conversion to a floating-point number.

Affected systems

  • k-meleon_project k-meleon 1.5.3
  • mozilla firefox 3.0.1
  • mozilla firefox 3.0.2
  • mozilla firefox 3.0.3
  • mozilla firefox 3.0.4
  • mozilla firefox 3.0.5
  • mozilla firefox 3.0.6
  • mozilla firefox 3.0.7
  • mozilla firefox 3.0.8
  • mozilla firefox 3.0.9
  • mozilla firefox 3.0.10
  • mozilla firefox 3.0.11
  • mozilla firefox 3.0.12
  • mozilla firefox 3.0.13
  • mozilla firefox 3.0.14
  • mozilla firefox 3.5
  • mozilla firefox 3.5.1
  • mozilla firefox 3.5.2
  • mozilla firefox 3.5.3
  • mozilla seamonkey 1.1.8
  • freebsd freebsd 6.4
  • freebsd freebsd 7.2
  • netbsd netbsd 5.0
  • openbsd openbsd 4.5

Ease of attack

CVE-2009-0689:

Access Vector NETWORK

Access Complexity MEDIUM

Authentication NONE

False positives

None known

False negatives

None known

Corrective action

Upgrade to the latest non-affected version of the software.

Apply the appropriate vendor supplied patches.

Contributors

  • Talos research team.
  • This document was generated from data supplied by the national vulnerability database, a product of the national institute of standards and technology.
  • For more information see nvd.

Additional References