Think you have a false positive on this rule?

Sid 1-1829

Message

SERVER-APACHE Apache Tomcat TroubleShooter servlet access

Summary

The default installation of Apache Tomcat 4.0 through 4.1 and 3.0 through 3.3.1 allows remote attackers to obtain the installation path and other sensitive system information via the (1) SnoopServlet or (2) TroubleShooter example servlets.

Impact

CVSS base score 5.0 CVSS impact score 2.9 CVSS exploitability score 10.0 confidentialityImpact PARTIAL integrityImpact NONE availabilityImpact NONE

Detailed information

Affected systems

  • apache tomcat 3.0
  • apache tomcat 3.1
  • apache tomcat 3.1.1
  • apache tomcat 3.2
  • apache tomcat 3.2.1
  • apache tomcat 3.2.3
  • apache tomcat 3.2.4
  • apache tomcat 3.3
  • apache tomcat 3.3.1
  • apache tomcat 4.0.0
  • apache tomcat 4.0.1
  • apache tomcat 4.0.2
  • apache tomcat 4.0.3
  • apache tomcat 4.1.0

Ease of attack

False positives

None known

False negatives

None known

Corrective action

Upgrade to the latest non-affected version of the software.

Apply the appropriate vendor supplied patches.

Contributors

  • Talos research team.
  • This document was generated from data supplied by the national vulnerability database, a product of the national institute of standards and technology.
  • For more information see nvd.

Additional References