Think you have a false positive on this rule?

Sid 1-43748

Message

BROWSER-FIREFOX Mozilla Firefox BOM character cross site scripting attempt

Summary

Mozilla Firefox before 2.0.0.17 and 3.x before 3.0.2, Thunderbird before 2.0.0.17, and SeaMonkey before 1.1.12 allow remote attackers to bypass cross-site scripting (XSS) protection mechanisms and conduct XSS attacks via byte order mark (BOM) characters that are removed from JavaScript code before execution, aka "Stripped BOM characters bug."

Impact

CVSS base score 4.3 CVSS impact score 2.9 CVSS exploitability score 8.6 confidentialityImpact NONE integrityImpact PARTIAL availabilityImpact PARTIAL

CVE-2008-4065:

CVSS base score 4.3

CVSS impact score 2.9

CVSS exploitability score 8.6

Confidentiality Impact NONE

Integrity Impact PARTIAL

Availability Impact NONE

Detailed information

CVE-2008-4065: Mozilla Firefox before 2.0.0.17 and 3.x before 3.0.2, Thunderbird before 2.0.0.17, and SeaMonkey before 1.1.12 allow remote attackers to bypass cross-site scripting (XSS) protection mechanisms and conduct XSS attacks via byte order mark (BOM) characters that are removed from JavaScript code before execution, aka "Stripped BOM characters bug."

Affected systems

  • mozilla firefox 0.8
  • mozilla firefox 0.9
  • mozilla firefox 0.9.1
  • mozilla firefox 0.9.2
  • mozilla firefox 0.9.3
  • mozilla firefox 0.9_rc
  • mozilla firefox 0.10
  • mozilla firefox 0.10.1
  • mozilla firefox 1.0
  • mozilla firefox 1.0.1
  • mozilla firefox 1.0.2
  • mozilla firefox 1.0.3
  • mozilla firefox 1.0.4
  • mozilla firefox 1.0.5
  • mozilla firefox 1.0.6
  • mozilla firefox 1.0.7
  • mozilla firefox 1.0.8
  • mozilla firefox 1.5
  • mozilla firefox 1.5.0.1
  • mozilla firefox 1.5.0.2
  • mozilla firefox 1.5.0.3
  • mozilla firefox 1.5.0.4
  • mozilla firefox 1.5.0.5
  • mozilla firefox 1.5.0.6
  • mozilla firefox 1.5.0.7
  • mozilla firefox 1.5.0.8
  • mozilla firefox 1.5.0.9
  • mozilla firefox 1.5.0.10
  • mozilla firefox 1.5.0.11
  • mozilla firefox 1.5.0.12
  • mozilla firefox 1.5.1
  • mozilla firefox 1.5.2
  • mozilla firefox 1.5.3
  • mozilla firefox 1.5.4
  • mozilla firefox 1.5.5
  • mozilla firefox 1.5.6
  • mozilla firefox 1.5.7
  • mozilla firefox 1.5.8
  • mozilla firefox 1.8
  • mozilla firefox 2.0
  • mozilla firefox 2.0.0.1
  • mozilla firefox 2.0.0.10
  • mozilla firefox 2.0.0.11
  • mozilla firefox 2.0.0.12
  • mozilla firefox 2.0.0.13
  • mozilla firefox 2.0.0.14
  • mozilla firefox 2.0.0.15
  • mozilla firefox 2.0.0.16
  • mozilla firefox 3.0
  • mozilla firefox 3.0.1
  • mozilla seamonkey *
  • mozilla seamonkey 1.0
  • mozilla seamonkey 1.0.1
  • mozilla seamonkey 1.0.2
  • mozilla seamonkey 1.0.3
  • mozilla seamonkey 1.0.4
  • mozilla seamonkey 1.0.5
  • mozilla seamonkey 1.0.6
  • mozilla seamonkey 1.0.7
  • mozilla seamonkey 1.0.8
  • mozilla seamonkey 1.0.9
  • mozilla seamonkey 1.0.99
  • mozilla seamonkey 1.1
  • mozilla seamonkey 1.1.1
  • mozilla seamonkey 1.1.10
  • mozilla seamonkey 1.1.11
  • mozilla thunderbird *
  • mozilla thunderbird 0.1
  • mozilla thunderbird 0.2
  • mozilla thunderbird 0.3
  • mozilla thunderbird 0.4
  • mozilla thunderbird 0.5
  • mozilla thunderbird 0.6
  • mozilla thunderbird 0.7
  • mozilla thunderbird 0.7.1
  • mozilla thunderbird 0.7.2
  • mozilla thunderbird 0.7.3
  • mozilla thunderbird 0.8
  • mozilla thunderbird 0.9
  • mozilla thunderbird 1.0
  • mozilla thunderbird 1.0.1
  • mozilla thunderbird 1.0.2
  • mozilla thunderbird 1.0.3
  • mozilla thunderbird 1.0.4
  • mozilla thunderbird 1.0.5
  • mozilla thunderbird 1.0.6
  • mozilla thunderbird 1.0.7
  • mozilla thunderbird 1.0.8
  • mozilla thunderbird 1.5
  • mozilla thunderbird 1.5.0.1
  • mozilla thunderbird 1.5.0.2
  • mozilla thunderbird 1.5.0.3
  • mozilla thunderbird 1.5.0.4
  • mozilla thunderbird 1.5.0.6
  • mozilla thunderbird 1.5.0.7
  • mozilla thunderbird 1.5.0.8
  • mozilla thunderbird 1.5.0.9
  • mozilla thunderbird 1.5.0.10
  • mozilla thunderbird 1.5.0.11
  • mozilla thunderbird 1.5.1
  • mozilla thunderbird 1.5.2
  • mozilla thunderbird 1.7.1
  • mozilla thunderbird 1.7.3
  • mozilla thunderbird 2.0.0.0
  • mozilla thunderbird 2.0.0.1
  • mozilla thunderbird 2.0.0.2
  • mozilla thunderbird 2.0.0.3
  • mozilla thunderbird 2.0.0.4
  • mozilla thunderbird 2.0.0.5
  • mozilla thunderbird 2.0.0.6
  • mozilla thunderbird 2.0.0.8
  • mozilla thunderbird 2.0.0.9
  • mozilla thunderbird 2.0.0.11
  • mozilla thunderbird 2.0.0.12
  • mozilla thunderbird 2.0.0.13
  • mozilla thunderbird 2.0.0.14
  • mozilla thunderbird 2.0.0.15
  • mozilla thunderbird 2.0.0.16
  • mozilla thunderbird 2.0_.4
  • mozilla thunderbird 2.0_.5
  • mozilla thunderbird 2.0_.6
  • mozilla thunderbird 2.0_.9
  • mozilla thunderbird 2.0_.12
  • mozilla thunderbird 2.0_.13
  • mozilla thunderbird 2.0_.14
  • mozilla thunderbird 2.0_8

Ease of attack

CVE-2008-4065:

Access Vector NETWORK

Access Complexity MEDIUM

Authentication NONE

False positives

None known

False negatives

None known

Corrective action

Upgrade to the latest non-affected version of the software.

Apply the appropriate vendor supplied patches.

Contributors

  • Talos research team.
  • This document was generated from data supplied by the national vulnerability database, a product of the national institute of standards and technology.
  • For more information see nvd.

Additional References