Think you have a false positive on this rule?

Sid 1-35855

Message

SERVER-WEBAPP PHP exififdmake_value thumbnail heap buffer overflow attempt

Summary

The exififdmakevalue function in exif.c in the EXIF extension in PHP before 5.4.34, 5.5.x before 5.5.18, and 5.6.x before 5.6.2 operates on floating-point arrays incorrectly, which allows remote attackers to cause a denial of service (heap memory corruption and application crash) or possibly execute arbitrary code via a crafted JPEG image with TIFF thumbnail data that is improperly handled by the exifthumbnail function.

Impact

CVSS base score 6.8 CVSS impact score 6.4 CVSS exploitability score 8.6 confidentialityImpact PARTIAL integrityImpact PARTIAL availabilityImpact PARTIAL

CVE-2014-3670:

CVSS base score 6.8

CVSS impact score 6.4

CVSS exploitability score 8.6

Confidentiality Impact PARTIAL

Integrity Impact PARTIAL

Availability Impact PARTIAL

Detailed information

CVE-2014-3670: The exififdmakevalue function in exif.c in the EXIF extension in PHP before 5.4.34, 5.5.x before 5.5.18, and 5.6.x before 5.6.2 operates on floating-point arrays incorrectly, which allows remote attackers to cause a denial of service (heap memory corruption and application crash) or possibly execute arbitrary code via a crafted JPEG image with TIFF thumbnail data that is improperly handled by the exifthumbnail function.

Affected systems

  • php php 5.4.0
  • php php 5.4.1
  • php php 5.4.2
  • php php 5.4.3
  • php php 5.4.4
  • php php 5.4.5
  • php php 5.4.6
  • php php 5.4.7
  • php php 5.4.8
  • php php 5.4.9
  • php php 5.4.10
  • php php 5.4.11
  • php php 5.4.12
  • php php 5.4.13
  • php php 5.4.14
  • php php 5.4.15
  • php php 5.4.16
  • php php 5.4.17
  • php php 5.4.18
  • php php 5.4.19
  • php php 5.4.20
  • php php 5.4.21
  • php php 5.4.22
  • php php 5.4.23
  • php php 5.4.24
  • php php 5.4.25
  • php php 5.4.26
  • php php 5.4.27
  • php php 5.4.28
  • php php 5.4.29
  • php php 5.4.30
  • php php 5.4.31
  • php php 5.4.32
  • php php 5.4.33
  • php php 5.5.0
  • php php 5.5.1
  • php php 5.5.2
  • php php 5.5.3
  • php php 5.5.4
  • php php 5.5.5
  • php php 5.5.6
  • php php 5.5.7
  • php php 5.5.8
  • php php 5.5.9
  • php php 5.5.10
  • php php 5.5.11
  • php php 5.5.12
  • php php 5.5.13
  • php php 5.5.14
  • php php 5.5.15
  • php php 5.5.16
  • php php 5.5.17
  • php php 5.6.0
  • php php 5.6.1

Ease of attack

CVE-2014-3670:

Access Vector NETWORK

Access Complexity MEDIUM

Authentication NONE

False positives

None known

False negatives

None known

Corrective action

Upgrade to the latest non-affected version of the software.

Apply the appropriate vendor supplied patches.

Contributors

  • Talos research team.
  • This document was generated from data supplied by the national vulnerability database, a product of the national institute of standards and technology.
  • For more information see nvd.

Additional References