Think you have a false positive on this rule?

Sid 1-34973

Message

SERVER-OTHER Apache mod_include buffer overflow attempt

Summary

Buffer overflow in the gettag function in modinclude for Apache 1.3.x to 1.3.32 allows local users who can create SSI documents to execute arbitrary code as the apache user via SSI (XSSI) documents that trigger a length calculation error.

Impact

CVSS base score 6.9 CVSS impact score 10.0 CVSS exploitability score 3.4 confidentialityImpact COMPLETE integrityImpact COMPLETE availabilityImpact COMPLETE

CVE-2004-0940:

CVSS base score 6.9

CVSS impact score 10.0

CVSS exploitability score 3.4

Confidentiality Impact COMPLETE

Integrity Impact COMPLETE

Availability Impact COMPLETE

Detailed information

CVE-2004-0940: Buffer overflow in the gettag function in modinclude for Apache 1.3.x to 1.3.32 allows local users who can create SSI documents to execute arbitrary code as the apache user via SSI (XSSI) documents that trigger a length calculation error.

Affected systems

  • apache http_server 1.3
  • apache http_server 1.3.1
  • apache http_server 1.3.3
  • apache http_server 1.3.4
  • apache http_server 1.3.6
  • apache http_server 1.3.7
  • apache http_server 1.3.9
  • apache http_server 1.3.11
  • apache http_server 1.3.12
  • apache http_server 1.3.14
  • apache http_server 1.3.17
  • apache http_server 1.3.18
  • apache http_server 1.3.19
  • apache http_server 1.3.20
  • apache http_server 1.3.22
  • apache http_server 1.3.23
  • apache http_server 1.3.24
  • apache http_server 1.3.25
  • apache http_server 1.3.26
  • apache http_server 1.3.27
  • apache http_server 1.3.28
  • apache http_server 1.3.29
  • apache http_server 1.3.31
  • apache http_server 1.3.32
  • openpkg openpkg 2.0
  • openpkg openpkg 2.1
  • openpkg openpkg 2.2
  • openpkg openpkg current
  • hp hp-ux 11.00
  • hp hp-ux 11.11
  • hp hp-ux 11.20
  • hp hp-ux 11.22
  • slackware slackware_linux 8.0
  • slackware slackware_linux 8.1
  • slackware slackware_linux 9.0
  • slackware slackware_linux 9.1
  • slackware slackware_linux 10.0
  • slackware slackware_linux current
  • suse suse_linux 8.0
  • suse suse_linux 8.1
  • suse suse_linux 8.2
  • suse suse_linux 9.0
  • suse suse_linux 9.1
  • suse suse_linux 9.2
  • trustix secure_linux 1.5

Ease of attack

CVE-2004-0940:

Access Vector LOCAL

Access Complexity MEDIUM

Authentication NONE

False positives

None known

False negatives

None known

Corrective action

Upgrade to the latest non-affected version of the software.

Apply the appropriate vendor supplied patches.

Contributors

  • Talos research team.
  • This document was generated from data supplied by the national vulnerability database, a product of the national institute of standards and technology.
  • For more information see nvd.

Additional References