Think you have a false positive on this rule?

Sid 1-31361

Summary:

    SERVER-OTHER OpenSSL DTLSv1.0 handshake fragment buffer overrun attempt

Impact:

    Confidentiality Impact: PARTIAL Integrity Impact: PARTIAL Availability Impact: PARTIAL

Detailed Information:

    The dtls1_reassemble_fragment function in d1_both.c in OpenSSL before 0.9.8za, 1.0.0 before 1.0.0m, and 1.0.1 before 1.0.1h does not properly validate fragment lengths in DTLS ClientHello messages, which allows remote attackers to execute arbitrary code or cause a denial of service (buffer overflow and application crash) via a long non-initial fragment.

Affected Systems:

    redhat storage 2.1
    openssl openssl 0.9.8
    redhat enterprise linux 6
    openssl openssl 1.0.1g
    openssl openssl 1.0.1f
    openssl openssl 1.0.1e
    openssl openssl 1.0.1d
    openssl openssl 1.0.1a
    openssl openssl 1.0.1c
    openssl openssl 1.0.1b
    fedoraproject fedora
    openssl openssl 0.9.8e
    openssl openssl 1.0.0h
    openssl openssl 0.9.8f
    openssl openssl 1.0.0g
    openssl openssl 0.9.8s
    openssl openssl 1.0.0j
    openssl openssl 0.9.8t
    openssl openssl 1.0.0i
    openssl openssl 0.9.8i
    openssl openssl 0.9.8j
    openssl openssl 0.9.8g
    openssl openssl 1.0.0f
    openssl openssl 0.9.8h
    openssl openssl 0.9.8m beta1
    openssl openssl 1.0.0e
    openssl openssl 0.9.8m
    openssl openssl 0.9.8n
    openssl openssl 0.9.8q
    openssl openssl 0.9.8r
    openssl openssl 0.9.8o
    openssl openssl 0.9.8p
    openssl openssl 0.9.8u
    openssl openssl 0.9.8v
    openssl openssl 0.9.8y
    openssl openssl 1.0.0d
    openssl openssl 1.0.0c
    openssl openssl 0.9.8w
    openssl openssl 0.9.8x
    openssl openssl 1.0.0b
    openssl openssl 1.0.0a
    openssl openssl 1.0.0l
    openssl openssl 1.0.0k
    openssl openssl 1.0.1
    openssl openssl 1.0.1 beta1
    openssl openssl 1.0.0 beta1
    openssl openssl 1.0.1 beta2
    openssl openssl 1.0.0 beta2
    openssl openssl 1.0.1 beta3
    openssl openssl 1.0.0 beta3
    openssl openssl 1.0.0 beta4
    openssl openssl 1.0.0 beta5
    openssl openssl 0.9.8c
    openssl openssl 0.9.8d
    openssl openssl 1.0.0
    openssl openssl 0.9.8k
    openssl openssl 0.9.8l
    openssl openssl 0.9.8a
    openssl openssl 0.9.8b

Attack Scenarios:

    No data available

False Positives:

    None known

False Negatives:

    None known

Corrective Action:

    Upgrade to the latest non-affected version
    Apply vendor-provided patches

Contributors:

    No data available

Additional References: