Think you have a false positive on this rule?

Sid 1-30199

Message

SERVER-WEBAPP PHP DateInterval heap buffer overread denial of service attempt

Summary

The scan function in ext/date/lib/parseisointervals.c in PHP through 5.5.6 does not properly restrict creation of DateInterval objects, which might allow remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted interval specification.

Impact

CVSS base score 5.0 CVSS impact score 2.9 CVSS exploitability score 10.0 confidentialityImpact NONE integrityImpact NONE availabilityImpact NONE

CVE-2013-6712:

CVSS base score 5.0

CVSS impact score 2.9

CVSS exploitability score 10.0

Confidentiality Impact NONE

Integrity Impact NONE

Availability Impact PARTIAL

Detailed information

CVE-2013-6712: The scan function in ext/date/lib/parseisointervals.c in PHP through 5.5.6 does not properly restrict creation of DateInterval objects, which might allow remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted interval specification.

Affected systems

  • php php 5.5.0
  • php php 5.5.1
  • php php 5.5.2
  • php php 5.5.3
  • php php 5.5.4
  • php php 5.5.5
  • php php 5.5.6
  • apple macosx 10.10.2
  • novell opensuse 11.4
  • novell opensuse 12.2
  • novell opensuse 12.3
  • novell opensuse 13.1

Ease of attack

CVE-2013-6712:

Access Vector NETWORK

Access Complexity LOW

Authentication NONE

False positives

None known

False negatives

None known

Corrective action

Upgrade to the latest non-affected version of the software.

Apply the appropriate vendor supplied patches.

Contributors

  • Talos research team.
  • This document was generated from data supplied by the national vulnerability database, a product of the national institute of standards and technology.
  • For more information see nvd.

Additional References

  • bugs.php.net/bug.php?id=66060