Think you have a false positive on this rule?

Sid 1-11679

Message

SERVER-APACHE Apache mod_rewrite buffer overflow attempt

Summary

Off-by-one error in the ldap scheme handling in the Rewrite module (mod_rewrite) in Apache 1.3 from 1.3.28, 2.0.46 and other versions before 2.0.59, and 2.2, when RewriteEngine is enabled, allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via crafted URLs that are not properly handled using certain rewrite rules.

Impact

CVSS base score 7.6 CVSS impact score 10.0 CVSS exploitability score 4.9 confidentialityImpact COMPLETE integrityImpact COMPLETE availabilityImpact COMPLETE

CVE-2006-3747:

CVSS base score 7.6

CVSS impact score 10.0

CVSS exploitability score 4.9

Confidentiality Impact COMPLETE

Integrity Impact COMPLETE

Availability Impact COMPLETE

Detailed information

CVE-2006-3747: Off-by-one error in the ldap scheme handling in the Rewrite module (mod_rewrite) in Apache 1.3 from 1.3.28, 2.0.46 and other versions before 2.0.59, and 2.2, when RewriteEngine is enabled, allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via crafted URLs that are not properly handled using certain rewrite rules.

Affected systems

  • apache http_server 1.3.3
  • apache http_server 1.3.4
  • apache http_server 1.3.5
  • apache http_server 1.3.6
  • apache http_server 1.3.7
  • apache http_server 1.3.8
  • apache http_server 1.3.9
  • apache http_server 1.3.28
  • apache http_server 1.3.29
  • apache http_server 1.3.30
  • apache http_server 1.3.31
  • apache http_server 1.3.32
  • apache http_server 1.3.33
  • apache http_server 2.0.46
  • apache http_server 2.0.47
  • apache http_server 2.0.48
  • apache http_server 2.0.49
  • apache http_server 2.0.50
  • apache http_server 2.0.51
  • apache http_server 2.0.52
  • apache http_server 2.0.53
  • apache http_server 2.0.54
  • apache http_server 2.0.55
  • apache http_server 2.0.56
  • apache http_server 2.0.57
  • apache http_server 2.0.58
  • ubuntu ubuntu_linux 5.04
  • ubuntu ubuntu_linux 5.10
  • ubuntu ubuntulinux 6.06lts

Ease of attack

CVE-2006-3747:

Access Vector NETWORK

Access Complexity HIGH

Authentication NONE

False positives

None known

False negatives

None known

Corrective action

Upgrade to the latest non-affected version of the software.

Apply the appropriate vendor supplied patches.

Contributors

  • Talos research team.
  • This document was generated from data supplied by the national vulnerability database, a product of the national institute of standards and technology.
  • For more information see nvd.

Additional References